Note:
To change the product logo for your own print manual or PDF, click "Tools > Manual Designer" and modify the print manual template.
Title page 1

Use this page to introduce the product

by IPDS Technologies AG

This is "Title Page 1" - you may use this page to introduce your product, show title, author, copyright, company logos, etc.

This page intentionally starts on an odd page, so that it is on the right half of an open book from the reader's point of view. This is the reason why the previous page was blank (the previous page is the back side of the cover).
AFP Printer

© 2014 IPDS Technologies AG

All rights reserved. No parts of this work may be reproduced in any form or by any means - graphic, electronic, or mechanical, including photocopying, recording, taping, or information storage and retrieval systems - without the written permission of the publisher.

Products that are referred to in this document may be either trademarks and/or registered trademarks of the respective owners. The publisher and the author make no claim to these trademarks.

While every precaution has been taken in the preparation of this document, the publisher and the author assume no responsibility for errors or omissions, or for damages resulting from the use of information contained in this document or from the use of programs and source code that may accompany it. In no event shall the publisher and the author be liable for any loss of profit or any other commercial damage caused or alleged to have been caused directly or indirectly by this document.

Printed: November 2014 in (wherever you are located)

Special thanks to:

All the people who contributed to this document, to mum and dad and grandpa, to my sisters and brothers and mothers in law, to our secretary Kathrin, to the graphic artist who created this great product logo on the cover page (sorry, don't remember your name at the moment but you did a great work), to the pizza service down the street (your daily Capricciosas saved our lives), to the copy shop where this document will be duplicated, and and and...

Last not least, we want to thank EC Software who wrote this great help tool called HELP & MANUAL which printed this document.
# Table of Contents

**Foreword**  

**Part I  Introduction**  
1 Overview

- What is AFP .......................................................... 9  
- What is AFP Architecture ......................................... 10  
- What is AFPDS ...................................................... 11  
- Why use AFP .......................................................... 11  
2 Features ........................................................................ 12  

**Part II  Installing**  
1 Overview ........................................................................ 15  
2 Silent Install .................................................................... 16  
3 Proxy Settings ................................................................... 16  
4 Central Deployment ........................................................ 16  

**Part III  Creating AFP**  
1 Creating an overlay..................................................... 20  
2 Creating a document.................................................... 21  
3 Creating a page segment............................................... 23  
4 Creating a medium overlay ........................................... 26  

**Part IV  Output Options**  
1 Paper Size ...................................................................... 29  
2 Page Orientation .......................................................... 30  

**Part V  Clipping**  
1 Clip Method .................................................................... 34  
2 Clip Area ......................................................................... 35  
3 Medium Origin .............................................................. 36  
4 Measurement ................................................................. 37  

**Part VI  Image Options**  
1 Color Options .............................................................. 41  
2 Graphics Options .......................................................... 42  
3 Grayscale Method ......................................................... 43  
4 Compression Method ..................................................... 44  
5 Intensity and Contrast ..................................................... 45  

© 2014 IPDS Technologies AG
Part VII  Font Options  47
  1  EBCDIC .............................................................. 48
  2  Use Text Rules .................................................. 49
  3  Maintain Text Order ......................................... 50
  4  Font Type .......................................................... 51
  5  Text Support ....................................................... 52
  6  Font Substitution ................................................ 53
      For Font .......................................................... 54
      Use AFP Character Set ..................................... 55
      TrueType Font Options .................................... 56
  7  Code Page .......................................................... 57
  8  Output Fidelity .................................................... 58

Part VIII  Advanced Options  61
  1  Image Resolution ............................................. 61
  2  Print text as image ............................................ 62
  3  Color Management ........................................... 63
  4  Compressed Images .......................................... 63
  5  Inline Form Definition .................................... 64
      Duplex Options ................................................... 65
      Finishing Options ............................................. 65
      Destination Bin Options .................................. 66
      Medium Overlay Options ................................ 67
      Form To Tray Assignment Options ..................... 67

Part IX  Viewing AFP  69
  1  IBM AFP Workbench Viewer ............................. 69

Part X  Purchase  72

Part XI  Registration  74

Part XII  Support  76

Index  0
Foreword

This is just another title page placed between table of contents and topics
Top Level Intro

This page is printed before a new top-level chapter starts

Part I
1 Introduction

User's Guide
for
AFP Printer

(C) Copyright 2010-2015 IPDS Technologies AG. All Rights Reserved


1.1 Overview

This User Guide describes how to create AFP document, overlay, medium overlay, and page segment by printing to the AFP Printer on the Microsoft Windows systems.

It supplements the standard reference documents on AFP creation by
providing more specific “how to” information, such as diagrams, screen captures, and working examples. It addresses the AFP creation from Microsoft Word, Microsoft Excel, Microsoft PowerPoint, Microsoft Visio, Microsoft Photo Wizard, Adobe Photoshop, and other print-enabling software.

This document is intended for customers, business partners, and systems specialists who need to understand the fundamentals of AFP creation on the Microsoft Windows systems. It is designed to help you develop or advise others concerning the design and development of AFP enabled and IPDS powered applications.

1.1.1 What is AFP

Advanced Function Printing (AFP) is a document format and presentation architecture originally developed by IBM to drive its printers and support the production of variable data printing on laser printers, and later provides for document and information presentation independent of specific applications and devices.

The first software program to produce this format and to drive the IBM printers was the so called Print Service Facility (PSF), which is still until today found in IBM's Mainframes. PSF is fed with the input data to be printed and the definitions on how to organize the data on the page, i.e. PAGEDEF (Page Definition) and FORMDEF (Form Definition). It allows electronic forms to be printed on named OVERLAYS.

PSF is not only able to format the documents, but also to drive the AFP printers, or the Intelligent Printer Data Stream (IPDS) compatible printers to be more precise. IPDS is a host-to-printer data stream used for AFP subsystems that provides an attachment-independent interface for controlling and managing.

IPDS format is a bidirectional format where the software is constantly in control of the printer and knows at all times the status of the pages that were sent to the printer, making it an ideal format for high volume production printers, that print hundreds of pages within a minute.

IBM also offered the PSF software to drive the IPDS printers using the AFP format not only on the mainframe, but also on all of the their platforms, so there were PSF/390 (for the OS/390 mainframe), PSF/6000 (for the RS/6000 AIX9), PSF/400 (for the AS/400) and PSF/2 running under OS/2. Unfortunately all of these behaved slightly different and IBM renamed PSF then into IBM InfoPrint Manager.

In 1984 when storage space was still an expensive commodity, the AFP format was designed to be very small, which is why still today it is a very popular format for data exchange that seconds to Adobe Portable Document Format (PDF) and to manage high volumes of documents,
such as banks, telecoms and insurances. The format originates from the MVS environment so it typically uses the EBCDIC based codepages. As with all page description languages (like PostScript, PDF, and PCL) it is necessary to use a viewer, usually it's the widely-used viewer, IBM AFP Workbench Viewer, in order to display the pages.

One of the more notable features of AFP printers is that output data can be placed at any addressable point on a page. This capability is called all points addressability (APA). APA gives AFP prints the freedom to create output anywhere on a page, as opposed to being limited to just line and character positions.

1.1.2 What is AFP Architecture

The AFP architecture consists of a number of sub-architectures:

MO:DCA-P (Mixed Object:Document Content Architecture-Presentation):

MO:DCA-P is occasionally called AFPDS (AFP Data Stream), which is a PDL (Page Description Language) file format that describes the text and graphics on a page. The 'Mixed Object' moniker refers to the fact that a MO:DCA file can contain multiple types of objects, including text, images, vector graphics, page separators, patch code, and barcodes. An application can simply include a string of digits along with controls that identify a specific type of barcode, and the rendering of bars will be performed on the output platform via either physical printer hardware or software emulation. A MO:DCA document consists of a sequential, ordered hierarchy of independent objects - documents, pages, data objects, and such resource objects as fonts and ICC profiles. Each object is delimited by one or more begin/end structures, and objects to be rendered specify presentation parameters and resource requirements in structures called "environment groups". Since the pages in MO:DCA documents are organized in sequential order, presentation can start as soon as the first page is received. The MO:DCA format is comparable to other PDLs such as Adobe PDF that specify distinct pages.

IPDS (Intelligent Printer Data Stream)

Known as a bi-directional protocol used between the host and the printer, IPDS is used to send the page-level data to the printer and to signal errors and accounting information back to the host server. The IPDS protocol, comparable to protocols like IPP (Internet Printing Protocol), allows the server to query a printer's available resources such as available memory, fonts, input trays, etc.

BCOCA (Bar Code Object Content Architecture)
BCOCA is used to describe and generate barcodes such as PDF417.

**CMOCA (Color Management Object Content Architecture)**

CMOCA defines resources that carry color management information, such as ICC profiles, tone transfer curves, and halftones.

**AFP GOCA (Graphics Object Content Architecture for AFP)**

AFP GOCA is used to define and generate vector graphics.

**IOCA (Image Object Content Architecture)**

IOCA is used to define and generate raster images.

**PTOCA (Presentation Text Object Content Architecture)**

PTOCA is used to define and generate text.

AFP also supports other industry-standard data formats using the concept of AFP object containers; examples are TIFF, GIF, JPEG (JFIF), EPS, and PDF. These objects can be mixed as peer objects on an AFP page with native AFP objects such as BCOCA, AFP GOCA, IOCA, and PTOCA objects.

### 1.1.3 What is AFPDS

AFPDS stands for Advanced Function Printing Data Stream, which is a data stream for advanced function printers independent of operating systems, independent of page printers, and portable across environments.

AFPDS is a structured data stream divided into components called objects. AFPDS includes text, images, graphics, and barcodes and references AFP resources (for example, overlays, page segments, and fonts).

### 1.1.4 Why use AFP

AFP (Advanced Function Printing) enables users to control formatting, the form of paper output, how a document is to be printed or viewed, and manage document storage and access in a distributed network across multiple operating system platforms. AFP is primarily employed in large enterprises for production **variable data printing** (VDP).

AFP applications allow users or print room operators to distribute print
jobs among a group of printers or in a printer farm, and to designate backup printers when one fails, which is called failover. In publishing AFP is considered to be a cornerstone of electronic document management (EDM) applications such as print-and-view, archive and retrieval, and Enterprise Report Management (ERM).

1.2 Features

AFP Printer key features include,

- Create AFP document, page segment, medium overlay, and overlay from any Windows application that supports printing
- Support a complete set of paper sizes
- Define custom paper size
- Paper type includes White, Colored, Transparent
- Flexible page orientation such as Portrait, Landscape, Portrait 180, Landscape 270
- Clip unprintable area or offset plus size
- Grayscale methods include photographic dither, compressed dither, diagonal dither, line art halftone
- Color options for bitonal (B/W, Color/White), 16 colors (4bit CMYK from 4bit RGB or 24bit RGB), and Full Color 32bit CMYK
- Color Management with ICC Profiles
- Adjust image resolution between 300x300 and 600x600 dpi
- JPEG and LZW compression algorithm for images
- Support level of graphic objects that comply with GOCA's DR/2V0 standard
- Easy Intensity and Contrast Controls
- Best output fidelity for TrueType fonts as references, inline resources, or images
- Optimize text in OpenType fonts, raster fonts, and outline fonts
- Maintain Output Fidelity for placement in character, word, and line level
- Print Text as Graphics for printers not fully-compliant to PT2, PT3 standards
- Support EBCDIC code page
- Adjust Text Order when necessary
- Font substitution of AFP character set with closely matched Windows font
- Enable or disable Text Rules to trade off between speed, file size, and output fidelity
- Support Inline Form Definition
- Rich Duplex Options like Simplex, Duplex, Tumble Duplex
- Various Form To Tray assignment
- Finishing Options include Staple, Punch, Edge, Saddle
- Produce AFP output files as smaller as possible
- Change file extension for AFP documents, page segments, medium overlays, and overlays
• Import and export settings of AFP Printer
• Automatic installation and configuration on Windows x86 and Windows x64
• Up to 600 dpi printing resolution
• Up to 1000 ppm engine speed
• Native support for 5000+ Windows applications
• Live update for new versions and plug-ins on Windows 32-bit and Windows 64-bit
• Free upgrades in the future for registered users
Top Level Intro

This page is printed before a new top-level chapter starts
2 Installing

This chapter introduces the concept of software installation on Microsoft Windows, how to adjust proxy settings in a corporate environment, and how to deploy AFP Printer in a centralized environment.

Before installing the AFP Printer software, please make sure that the following hardware requirements are met,

Intel or AMD processor 2.0GHZ or better
500MB free disk space
1024x768 or higher resolution for Display Monitor

AFP Printer on 64-bit operating systems offers approximately 30% performance gain over Windows 32-bit OS.

2.1 Overview

Before installing AFP Printer, make sure that you have Windows Print Spooler service enabled. This service is by default enabled by Microsoft Windows, and it is required by AFP Printer as well as required by all Inkjet and Laserjet printers.

To enable the Print Spooler service, just click Start->Run, and type in the following command,

```
SC.EXE start Spooler
```

The file name of the installer for AFP Printer is AFPPrinter_Setup.exe. And the installer installs an evaluation copy of the AFP Printer for users to try for up to 15 days.

To facilitate the installation, you are required to log on Microsoft Windows as Administrator or a Power User with the rights to install software. After you download AFPPrinter_Setup.exe from the web or obtain the file from a 3rd-party source, you need to right-click on the file, and choose 'Run As Administrator' on Microsoft Windows 7 and later operating systems to ensure that the installer is executed with elevated privilege so that installation won't fail.

The file name 'AFPPrinter_Setup.exe' is for the trial version of the AFP Printer, and the one for the full retail version differs.
2.2 Silent Install

AFP Printer can be installed in a completely silent way without any user interaction.

To start a silent installation, start the installer with the following switches,

`AFPPrinter_Setup.exe /SP- /VERYSILENT`

Sometimes a certain driver file might be in use by an application, and the file has to be replaced during next reboot. In this case, the installer might prompt user to restart the computer. To suppress the information, just use the following switches,

`AFPPrinter_Setup.exe /SP- /VERYSILENT /NORESTART`

If you need MSI package for installation, feel free to contact support@afpdriver.com

2.3 Proxy Settings

The installer of AFP Printer always perform a check to see if a new version of the AFP print driver is available on the web, and therefore an active Internet connection is highly desired by the installer.

In a corporate environment the users have to specify a proxy server to have access to the Internet in the web browser. The installer for AFP Printer is able to detect the proxy settings specified in Microsoft Internet Explorer.

If you haven't set up your proxy server, you can click Start->Run, and then type in the following command,

`Rundll32 Shell32.dll,Control_RunDLL Inetcpl.cpl,,4`

and then specify the proxy server name (or IP address), and the proxy server port.

2.4 Central Deployment

To deploy AFP Printer on all the workstations and laptops across your organizations, printer sharing will not work. You have to install AFP Printer onto each computer.

If you need an AFP Printer that can be installed on a server, and the AFP Printer can be shared as a network printer for all your client computers, you might consider our **AFP Server** product.
More information on AFP Server product can be found in our web site, http://www.afpdriver.com
Top Level Intro

This page is printed before a new top-level chapter starts
3 Creating AFP

AFP docs are created with the IBM Advanced Function Presentation Printer (AFP) Driver, which is a printer driver designed to produce AFP output from Microsoft Windows applications.

AFP docs make it possible to print PC documents on high-speed AFP system printers, produce electronic forms using your favorite PC application, and even create signatures and logos from existing or newly-scanned sources.

AFP docs can be created on a PC with Microsoft Windows installed. Creating AFP docs is as simple as printing.

AFP docs are categorized by output type as document, page segment, medium overlay, and overlay.

- **AFP documents**

  Using the AFP Printer, you can send your PC documents, such as Microsoft Word document, Microsoft Excel document et al, for printing on a high-speed AS/400 AFP system printer instead of overloading your desktop PC printer.

- **Page segments**

  Page segments are collections of predefined data that can be merged with other data on a page when the page is printed. They generally are used to print signatures or logos. Page segments may contain either IM images, IO images, vector graphics, and, with some limitations, pre-composed text.

  IM images are supported on all AFP Advanced Function Presentation printers. An IM image object specifies the content of an uncompressed raster image and its placement on a page. It is resolution and orientation. However, when printed on a printer of a different resolution from the image, if the printer supports IO images, the IM image is converted to IO image and scaled to the printer's resolution. This is done for most 300-dpi printers when 240-dpi images are used.

  IO images are supported only on the newer AFP Advanced Function Presentation printers. An IO image object (also known as IOCA), also specifies the content of a raster image. However, the image is resolution independent and can be either uncompressed or compressed with one of the following compression algorithms: IBM MRR, RL4, ABIC, G3MR (CCITT T.4 G3) and G4 MRR (CCITT T.6 G4). If IO images are used for printers that do not support them, the images will be scaled to the
printer's resolution, if necessary, and converted to an IM image at print time.

Graphics are supported on only the newer AFP Advanced Function Presentation printers. They are not supported on old printers. A graphic object specifies the content of a vector graphic and it, too, is resolution independent.

If you already have your business logos or signatures in PC format, you can include these in overlays, or perhaps create them as a separate resource, i.e. an AFP page segment. Captured at a PC-attached scanner, they can be imported into a PC application and then “printed” as a page segment.

• Overlays and Medium Overlays

An overlay may be either a medium overlay or a page overlay (page overlay is usually called overlay). Not all printers can support page overlays electronic forms.

The most common overlay is the medium overlay, which can be used to print same overlay on every page of data, print different overlays electronic forms on different copies of the same page, or print different overlays electronic forms on front and back of duplex page. It's a type of overlay that is called out in a form definition to be included on one or more pages of a document when it prints.

A page overlay is used to print different overlays electronic forms on different pages of a job, and/or print same overlay at different locations on different pages.

3.1 Creating an overlay

What is AFP overlay?

An overlay may be either a medium overlay or a page overlay (page overlay is usually called overlay). Not all printers can support page overlays electronic forms.

A page overlay is used to print different overlays electronic forms on different pages of a job, and/or print same overlay at different locations on different pages.

How to create AFP overlay?

1. Start your PC software (Here, we take Microsoft Excel as an example)
2. Open a Microsoft Excel spreadsheet
3. Select from main menu "File"->"Print"

4. Select Printer "AFP Printer"

5. Click the "Property" button on the right, and the follow window appears,

6. Select "Overlay" from the drop-down list of "Output Type"

7. Click "Apply" button and then click "OK" button to confirm your changes

8. Click "OK" in the Print Dialog of Microsoft Excel to confirm your "Print" command

9. A "Save-As" dialog will pop up, you can specify the folder and file name of the AFP document to be created.

3.2 Creating a document

What is AFP document?

Using the AFP Printer, you can send your PC documents, such as
Microsoft Word document, Microsoft Excel document et al, for printing on a high-speed AS/400 AFP system printer instead of overloading your desktop PC printer.

**How to create AFP document?**

1. Start your PC software (Here, we take Microsoft Word as an example)
2. Open a Microsoft Word document
3. Select from main menu "File"->"Print"
4. Select Printer "AFP Printer"
5. Click the "Property" button on the right, and the follow window appears,

![Advanced settings window](image)

6. Select "Document" from the drop-down list of "Output Type"
7. If you want to specify duplex printing and use a different drawer, highlight "Inline Form Definitions" and then click the "Form Definition..." button on the right,
You will get the **Inline Form Definition** dialog,

8. You can also specify an AFP (Medium) Overlay to be printed with your document, but you must ensure it is available as a separate resource on the system from which you want to print.

9. Click "OK" button to close the **Inline Form Definition** dialog.

10. Click "Apply" button and then click "OK" button to confirm your changes.

11. Click "OK" in the Print Dialog of Microsoft Word to confirm your "Print" command.

12. A "Save-As" dialog will pop up, you can specify the folder and file name of the AFP document to be created.

### 3.3 Creating a page segment

**What is AFP page segment?**

Page segments are collections of predefined data that can be merged with other data on a page when the page is printed. They generally are used to print signatures or logos. Page segments may contain either IM images, IO images, vector graphics, and, with some limitations, pre-composed text.
IM images are supported on all AFP enabled printers. An IM image object specifies the content of an uncompressed raster image and its placement on a page. It is resolution and orientation. However, when printed on a printer of a different resolution from the image, if the printer supports IO images, the IM image is converted to IO image and scaled to the printer's resolution. This is done for most 300-dpi printers when 240-dpi images are used.

IO images are supported only on the newer AFP enabled printers. An IO image object (also known as IOCA), also specifies the content of a raster image. However, the image is resolution independent and can be either uncompressed or compressed with one of the following compression algorithms: IBM MRR, RL4, ABIC, G3MR (CCITT T.4 G3) and G4 MRR (CCITT T.6 G4). If IO images are used for printers that do not support them, the images will be scaled to the printer's resolution, if necessary, and converted to an IM image at print time.

Graphics are supported on only the newer AFP enabled printers. They are not supported on old printers. A graphic object specifies the content of a vector graphic and it, too, is resolution independent.

If you already have your business logos or signatures in PC format, you can include these in overlays, or perhaps create them as a separate resource, i.e. an AFP page segment. Captured at a PC-attached scanner, they can be imported into a PC application and then “printed” as a page segment.

**How to create AFP page segment?**

1. Start your PC software (Here, we take Microsoft Access as an example)
2. Open a Microsoft Access database/document
3. Select from main menu "File"->"Print"
4. Select Printer "AFP Printer"
5. Click the "Property" button on the right, and the follow window appears,
6. Select "Page Segment" from the drop-down list of "Output Type"

7. Click "Apply" button and then click "OK" button to confirm your changes

8. For an image that occupies most or all of the page, leave the Top/Left and Width/Height settings at their default values. If you are producing a company logo or signature that typically occupies a small area of the page, you can place your logo in the top left-hand area of the page, and then change **Paper Size** to **User Defined** (for instance, 2.0 inches wide by 1.2 inches deep). This helps reduce the amount of surrounding white space you capture with the page segment and makes positioning it much easier.

8'. Alternatively, you can enter the coordinates of the top left-hand corner of the logo or area you want to capture in Top and Left in "Clip Limits..." options dialog, and change Width and Height as required (for instance, 2.0 inches by 1.2 inches). **NOTE:** This method does not work with certain Windows applications

8". Another method is to select the **Partial Print** option from your Windows application, which means that you print only an area of your spreadsheet or drawing, but not the whole area.
9. Click "OK" in the Print Dialog of Microsoft Access to confirm your "Print" command

10. A "Save-As" dialog will pop up, you can specify the folder and file name of the AFP document to be created.

3.4 Creating a medium overlay

What is AFP medium overlay?

An overlay may be either a medium overlay or a page overlay (page overlay is usually called overlay). Not all printers can support page overlays electronic forms.

The most common overlay is the medium overlay, which can be used to print same overlay on every page of data, print different overlays electronic forms on different copies of the same page, or print different overlays electronic forms on front and back of duplex page. It's a type of overlay that is called out in a form definition to be included on one or more pages of a document when it prints.

How to create AFP medium overlay?

1. Start your PC software (Here, we take Microsoft PowerPoint as an example)

2. Open a Microsoft PowerPoint slide

3. Select from main menu "File"->"Print"

4. Select Printer "AFP Printer"

5. Click the "Property" button on the right, and the follow window appears,
6. Select "Medium Overlay" from the drop-down list of "Output Type"

7. Click "Apply" button and then click "OK" button to confirm your changes

8. Click "OK" in the Print Dialog of Microsoft PowerPoint to confirm your "Print" command

9. A "Save-As" dialog will pop up, you can specify the folder and file name of the AFP document to be created.
Top Level Intro

This page is printed before a new top-level chapter starts
4 Output Options

The AFP drivers differ from normal printer drivers in that the output is Advanced Function Presentation Data Stream (AFPDS) instead of the more usual Printer Control Language (PCL), Personal Printer Data Stream (PPDS), PostScript, and others. You “print” to the AFP Printer to obtain the output in an AFP file just the same way as you normally print from any Windows application to an Inkjet or Laserjet printer.

There are a variety of output options, among which the most important options are paper size and page orientation.

Paper size specifies which type of media your document is printed on, for example, print each your Microsoft Word document page to an A4 size paper represented in an AFP document.

Page orientation describes the layout of your document, portrait or landscape or even complex.

4.1 Paper Size

To adjust the paper size settings, you can run the following command in Start->Run,

rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"

Or you can go to your Control Panel->Printers and Devices (only on Windows 10/8.1/8/7/Vista/2008/2012/2015) or Control Panel->Printers and Faxes (only on Windows 2000/XP/2003), and right-click on the "AFP Printer", and then choose "Printing Preferences".

In the Printing Preferences dialog, you see the Paper Size option.

The following paper sizes are supported by the AFP Printer,

Letter (8.5 x 11 inch)
Legal (8.5 x 14 inch)
Ledger (17 x 11 inch)
Executive (7.25 x 10.5 inch)
Tabloid (11 x 17 inch)
Statement (5.5 x 8.5 inch)
A3 (297 x 420 mm)
A4 (210 x 297 mm)

A4 Small (210 x 297 mm)
A5 (148 x 210 mm)
B4 (250 x 354 mm)
B5 (182 x 257 mm)
Folio (8.5 x 13 inch)
Quarto (215 x 275 mm)
Note (8.5 x 11 inch)
10 x 14 inch
11 x 17 inch
Envelope B4 (110 x 230 mm)
Envelope B5 (176 x 250 mm)
Envelope B6 (176 x 125 mm)
Envelope C3 (324 x 458 mm)
Envelope C4 (229 x 324 mm)
Envelope C5 (162 x 229 mm)
Envelope C6 (114 x 162 mm)
Envelope C65 (114 x 229 mm)
Envelope DL (110 x 220 mm)
Envelope #9 (3.875 x 8.875 inch)
Envelope #10 (4.125 x 9.5 inch)
Envelope #11 (4.5 x 10.375 inch)
Envelope #12 (4.75 x 11 inch)
Envelope #14 (5 x 11.5 inch)
Envelope Monarch (3.875 x 7.5 inch)
C Sheet
D Sheet
E Sheet
Continuous (13.2 x 8.5 inch)
Continuous (13.2 x 11 inch)
Continuous (13.2 x 14 inch)
User Defined (When this item is chosen, you are required to click the "User Defined..." button on the right and specify the height, width, and unit.)

NOTE: The paper size that you enter must exist on your printer, or printing any documents that are created with this paper size may fail. Neither height nor width must exceed the range of [1, 22].

4.2 Page Orientation

The following page orientation are supported by the AFP Printer,

Portrait
Landscape
Portrait 180
Landscape 270
To adjust the page orientation settings, you can run the following command in Start->Run,

rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"

Or you can go to your Control Panel->Printers and Devices (only on Windows 10/8.1/8/7/Vista/2008/2012/2015) or Control Panel->Printers and Faxes (only on Windows 2000/XP/2003), and right-click on the "AFP Printer", and then choose "Printing Preferences".

In the Printing Preferences dialog, you see the Orientation option.
Top Level Intro

This page is printed before a new top-level chapter starts
5  **Clipping**

AFP Printer offers a **Clip Limit Options** dialog to indicate how the AFP Printer should clip the output generated.

To show this dialog, you can run the following command in Start->Run, `rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"

Or you can go to your Control Panel->Printers and Devices (only on Windows 10/8.1/8/7/Vista/2008/2012/2015) or Control Panel->Printers and Faxes (only on Windows 2000/XP/2003), and right-click on the "AFP Printer", and then choose "Printing Preferences".

In the Printing Preferences dialog, you see an option "Clip Limits..." and a button "Properties..." on the right,

![Clip Limit Options dialog](image)

Click this button, and you will get the **Clip Limit Options** dialog,
5.1 Clip Method

Two kinds of clip methods are provided in AFP Printer,

**Unprintable area:**

This method is intended for document and medium overlays. You need to specify the amount of unprintable area on the top and bottom of the page, and for the left and right margins. For instance, the default margin in your printer is set to one quarter of an inch on all sides, but you may want to decrease this amount to take advantage of your printer’s ability to print closer to the edge.

**Offset plus size:**

This method is for page segments and overlays. You are required to specify the coordinates of the top-left corner of the area to be included in the page segment or overlay and the width and height of the area.

The following formula should be met,

1. Left offset + Width <= paper width
2. Top offset + Height <= paper height
5.2 Clip Area

You can set the area for the actual amount to clip. The value ranges are determined by the clip method selected.

The Top value determines how much to clip off the top of the page.

The Left value determines how much to clip off the left of the page.

The Bottom value determines how much to clip off the bottom of the page.

The Right value determines how much to clip off the right of the page.

The Width value determines how wide the clipped output should be.

The Height value determines indicates how high the clipped output should be.
5.3 Medium Origin

Medium origin indicates the \((X, Y)\) origin of the medium in the form definition (FORMDEF) to be used when a document is being printed. By default \(X=0.000\) and \(Y=0.000\). The upper bound for the \(X\) origin is the Left value, and the bound for the \(Y\) origin is the Top value.

Medium origin options **disappear** when the **Inline Form Definition** is set to **On**, because the medium origin always equals to \((0,0)\) in the inline form definition to be created.
5.4 **Measurement**

The unit of measurement can either be Inch or Millimeter.

You can choose the one of your preference.
Top Level Intro

This page is printed before a new top-level chapter starts
6 Image Options

AFP Printer offers an **Image Options** dialog to indicate how the AFP Printer should process images and graphics before generating the output.

When you print from some Windows applications to the AFP printer, they do not send halftone data directly to the printer, and the options you select for Color Options, Graphics Options, Grayscale Method, Compression Method, Intensity, and Contrast determine how your images and graphics are printed.

You may need to experiment with these options to get the best results.

To show this dialog, you can run the following command in Start->Run,

```
rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"
```

Or you can go to your Control Panel->Printers and Devices (only on Windows 7/8/Blue/Vista/2008/2012) or Control Panel->Printers and Faxes (only on Windows 2000/XP/2003), and right-click on the "AFP Printer", and then choose "Printing Preferences".

In the Printing Preferences dialog, you see an option "Image Options..." and a button "Properties..." immediately on the right of the option,

Click this button, and you will get the **Image Options** dialog,
6.1 Color Options

Four kinds of Color Options are available. The color option that you select determines how your AFP document (*.AFP), page segment (*.PSG), medium overlay (*.OLY), or overlay (*.OLY) looks like.

**Back / White (B/W)**
This bitonal option forces the AFP Printer to generate black and white images. Only black and white are available in the output AFP docs.

**Color / White (C/W)**
This bitonal option mandates the AFP Printer to generate single color and white images. Only the selected single color and white are available in the output AFP docs. The single color is Black by default, and you may change it to other colors but White as well.

**16 Colors - 4Bit CMYK / From RGB**
This option allows the creation of 16 colors images in the CMYK Color Space. The halftone algorithm is selected by the number of bits, either 4Bit or 32Bit, in the RGB Color Space.

**Full Colors - 32Bit CMYK**
This option allows the creation of 32-bit full-color image in the CMYK Color Space.

**NOTE:** CMYK stands for Cyan, Magenta, Yellow, and Black, and RGB is short for Red, Green, and Blue.
6.2 Graphics Options

Graphic Options determines the support level of graphics the AFP Printer generates. Three options are provided:

None
All graphic objects are rasterized into images.

Basic
Graphic objects comply with GOCA's DR/2V0 standard, which is a standard supported by all AFP enabled printers.

Enhanced
Graphic objects have additional drawing orders not support by GOCA's DR/2V0 standard. Not all AFP enabled printers support the additional drawing orders.

NOTE: GOCA is an architected collection of constructs for the interchange and presentation of graphic data. The AFP Printer uses constructs from the GOCA DR/2V0 and above.
6.3 Grayscale Method

Five grayscale methods are provided,

Default Dither
This method uses a 4 x 4 bit pattern of dots to emulate up to 16 levels of gray.

Photographic Dither
This method uses an 8 x 8 bit pattern of dots to emulate up to 64 levels of gray, producing a smooth, realistic, and photographic appearance. If you need soft contrasts between various shades of gray, you should not miss this dither.

Compressed Dither
This method uses an 8 x 8 bit pattern of horizontal lines to emulate up to 64 levels of gray, producing the smallest output, while still giving reasonable quality. This dither should not be applied to the full color images produced by a scanner.

Diagonal Dither
This method uses an 8 x 8 bit pattern of diagonal lines to emulate up to 64 levels of gray, producing a smooth, realistic appearance without the graininess otherwise produced using the Photographic Dither.

Line art halftone Dither
This method uses 32 different 8 x 8 bit patterns to produce 32 distinct levels of gray. Line art halftone Dither works well for images with intricate lines and fine detail such as clip art graphics. Unlike Photographic Dither and Diagonal Dither that provide soft contrasts.
between various shades of gray, the Line art halftone Dither provides solid lines and well-defined borders between various shades of gray.

6.4 Compression Method

This option, for most cases, is grayed out, unless the Full Color - 32Bit CMYK Color option is selected as the color option for AFP docs.
Full color image objects can be compressed using either the LZW or the JPEG compression algorithm. LZW compression is good for text-based content, and JPEG compression is recommended for photographic images.

6.5 **Intensity and Contrast**

Intensity Control and Contrast Control are grayed out when the grayscale method is Default dither; they are enabled when any other dither is selected as the grayscale method.

Intensity Control can be used to increase or decrease the lightness of image and graphics in the output AFP docs.

Contrast Control can be used to increase or decrease the contrast of image and graphics in the output AFP docs.

In most cases the two values do not need to be adjusted.
Top Level Intro

This page is printed before a new top-level chapter starts
7 Font Options

AFP Printer offers an **Font Options** dialog to indicate how the AFP Printer should process fonts before generating the output.

When you print from some Windows applications to the AFP printer, text printed in a certain font might not have a substitute in your table is printed as image. By setting up the Font Options, you can determine which AFP character set should be substituted for particular Windows fonts in your AFP output and what level of fidelity should be maintained.

You may need to experiment with these options to get the best results.

To show this dialog, you can run the following command in Start->Run, `rundll32.exe printui.dll, PrintUIEntry /p /n "AFP Printer"

In the Printing Preferences dialog, you see an option "Fonts..." and a button "Properties..." immediately on the right of the option,

Click this button, and you will get the **Font Options** dialog,
### 7.1 EBCDIC

Extended Binary Coded Decimal Interchange Code (EBCDIC) is an 8-bit character encoding (code page) employed mainly on IBM mainframe operating systems such as z/OS, OS/390, VM and VSE, as well as IBM midrange computer operating systems such as OS/400 and i5/OS (see also Binary Coded Decimal).

When the EBCDIC option is selected, the AFP Printer will convert all ASCII text into EBCDIC text. A valid EBCDIC code page must be specified in the Code Page column, or the text strings would otherwise print improperly.
The default EBCDIC code page is T1001140.

This EBCDIC option is by default disabled.

### 7.2 Use Text Rules

This **Use Text Rules** option allows you to trade off between speed, file size, and output fidelity.

When this option is enabled, the AFP Printer produces output files as smaller as possible. Smaller AFP files are usually printed faster by the target printer.
This option is by default enabled.

7.3 **Maintain Text Order**

This **Maintain Text Order** option determines the whether the AFP Printer should keep the text in the order it was received from the application where the Print command is issued.

When this option is enabled, the received text is kept in order; when it is disabled, the AFP Printer will order the text by font type and style improving performance as a result.
This option is by default disabled.

### 7.4 Font Type

Three options for Font Type are provided,

- **AFP Raster Fonts**
- **AFP Outline Fonts**
- **TrueType Fonts**

We recommend **TrueType fonts** among the three options so as to get the best output fidelity. Some AFP enabled printers require that the printers are configured to accept TrueType fonts.

**AFP Raster Fonts** are fonts whose graphic character shapes are defined by small raster patterns.

**AFP Outline Fonts** are fonts fully compliant to the Adobe Type 1 Font standards, and graphic character shapes are defined by mathematical equations rather than by raster patterns.

Please check with your printer manufacturer to see if your AFP enabled printer supports TrueType fonts, Raster Fonts, and Outline Fonts.
7.5 Text Support

This **Text Support** option determines the support level of text the AFP Printer generates. Two options are available for Text Support, **Basic** and **Enhanced Color**.

**Basic**
Text objects generated from AFP Printer are compliant to PT2 standards.

**Enhanced Color**
Text objects generated from AFP Printer are compliant to PT3 standards.

*NOTE:* PT2 standards only support the eight colors, red, blue, green, black, magenta, cyan, yellow, and brown. Whereas PT3 standards support a full spectrum RGB color space, i.e. all the 24-bit color values. PT3 is not supported by all AFP enabled printers.
7.6 Font Substitution

You can substitute a font in your table with a Windows font in the Font Process Table frame.
The **Font Process Table** frame contains three sub-frames,

For Font
Use AFP Character Set
TrueType Font Options

### 7.6.1 For Font

Choose a font in the **For Font** sub-frame as a replacement for the font in your table.

**Name**
Specify the name of the Windows font such as Arial.

**Style**
Specify the style of the Windows font such as Regular, Italic, Bold.

**Size**
Specify the size of the Windows font selected.

When you select a font in the drop-down list of all the available fonts installed on your Microsoft Windows system, the current substitution for the selected font, if available, is shown in the **Use AFP Character Set** sub-frame, as illustrated, C0H200B0 is for shown for Arial.
7.6.2 Use AFP Character Set

Choose a font in the **For Font** sub-frame as a replacement for the font in your table.

When you select a font in the drop-down list of all the available fonts installed on your Microsoft Windows system, the current substitution for the selected font, if available, is shown in the **Use AFP Character Set** sub-frame. For example, COH200B0 is a substitution for Arial.

You can add, modify, and delete a font substitution at any time. Any AFP character set that is substituted should have metrics that closely match the selected Windows font, or text in your AFP output will not be correctly placed. You can avoid some of these errors by varying the output fidelity.
More reference on AFP font mapping with Windows fonts, read the AFP Font Mapping Table.

### 7.6.3 TrueType Font Options

Three options are provided in the **TrueType Font Options** sub-frame.

**Create Reference**

This option directs the AFP Printer to create references for TrueType fonts, and it helps minimize the size of output files.

**Create Inline Resource**

This option directs the AFP Printer to embed a subset of TrueType fonts as inline resources in the AFP output, and thus produce larger output files.

**Generate Image**

This option directs the AFP Printer to rasterize the TrueType fonts and store fonts as image rather than text objects, and therefore create the largest output files.

*Note:* We recommend the **Create Reference** option for documents without text in special fonts. We suggest the choice of the **Create**
**Inline Resource** option for document with special fonts. We do not advice the use of the **Generate Image** option unless the target printer does not support TrueType fonts.

![Font Options](image)

### Code Page

Code page is another name for character encoding, which consists of a table of values describing the character set for a particular language. The term code page originated from IBM's EBCDIC-based mainframe systems.

The default code page for ASCII is T1001252 (Personal Computer: Desktop Publishing). You can enter your own code page to be used by the AFP Printer.

T1001252 works for most cases.
Like the **Use Text Rules** option, the **Output Fidelity** options can be used to trade off between speed, file size, and output fidelity.

Only text printed in substituted fonts will be impacted by the **Output Fidelity** options, whereas text printed as image will never be impacted.

Three methods are provided for Output Fidelity,

**Character**

This method places each character individually according to the metrics of the Windows font. Provides the greatest fidelity, it causes the driver to run slower and increases the size of your output file.

If the AFP character set that you are substituting has metrics that closely match your Windows fonts, this method is rarely used unless you do find incorrect character placement in the AFP output.

**Word**

This method places each word individually according to the metrics of the Windows font, thus providing a good compromise between speed, size, and fidelity. Recommended for most situations.
Line

This method places each line individually according to the metrics of the Windows font, thus generating the smallest output files that will be printed much faster.

Though this method might cause words to overlap in some cases, it provides considerable fidelity when your document is composed of individual lines in the same font and proper font substitutions have been set up in the AFP Printer.
Top Level Intro

This page is printed before a new top-level chapter starts
Advanced Options

AFP Printer offers many advanced options to indicate how the AFP Printer should process images and graphics before generating the output. You may need to experiment with these options to get the best results.

To show this dialog, you can run the following command in Start->Run,

```cmd
rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"
```

In the Printing Preferences dialog, you see the option "Print Text as Graphics" and "Inline Form Definition".

Color Management options are available in the Color Management tab of the AFP Printer Properties dialog, after you run the following command in Start->Run,

```cmd
rundll32.exe printui.dll, PrintUIEntry /p /n "AFP Printer"
```

Image Resolution and Compressed Images options can both be found in the "Device Settings" tab,

8.1 Image Resolution

Image Resolution can either be 300x300 or 600x600 DPI (Dot Per Inch). The principle of the choice is to match your target printer.
Most laserjet printers, such as IBM, Oce, InfoPrint printers, use AFP resources at 300 dpi even if they subsequently print the output at 600 dpi.

8.2 Print text as image

This option allows you to print text as vector-based font objects or rasterized images.

When this option is set to On, the AFP Printer processes text in your PC document as text wherever possible with graphics and shading being produced as image, and it makes it more efficient to produce text-based overlays and documents in terms of both the file size and the speed of viewing and printing.

When this option is set to Off, all text-based contents are processed as a series of images rather than as vector-based text.

We highly recommend this option to be set to On unless you find that certain text is missing or certain type of fonts are misinterpreted in the output AFP docs.
8.3 **Color Management**

Color Management options are only available on Microsoft Windows 10/8.1/8/7/Vista/2008/2012 or later operating systems, which can be found when you can go to your Control Panel->Printers and Devices, and right-click on the "AFP Printer", and then choose "Properties".

Color Management options are on the Color Management tab of the AFP Printer Properties tab, and you can specify an ICC profile for color space conversion.

8.4 **Compressed Images**

Compressed Images option is set to On by default. If you turn this option off, you get larger AFP document, page segment, or (medium) overlay.

Most laserjet printers, such as IBM, Oce, InfoPrint printers, is capable of decompressing images when a AFP document, page segment, or (medium) overlay is printed.

This option is set to Off only when the target printer is old and does not support image compression.
8.5 Inline Form Definition

AFP Printer offers an **Inline Form Definition Options** dialog to indicate how the AFP Printer should process images and graphics before generating the output.

You may need to experiment with these options to get the best results.

To show this dialog, you can run the following command in Start->Run,

```
rundll32.exe printui.dll, PrintUIEntry /e /n "AFP Printer"
```

Or you can go to your Control Panel->Printers and Devices (only on Windows 7/8/Blue/Vista/2008/2012) or Control Panel->Printers and Faxes (only on Windows 2000/XP/2003), and right-click on the "AFP Printer", and then choose "Printing Preferences".

In the Printing Preferences dialog, you see an option "Inline Form Definition", turn it from Off to On, and a button "Form Definitions..." appears immediately on the right of the option,

Click this button, and you will get the **Inline Form Definition** dialog,
8.5.1 Duplex Options

Duplex Options are embedded parameters and/or commands in the AFP docs (document, page segment, overlay, or medium overlay) to indicate on which sides of the output sheet the target printer prints your AFP docs. The target printer can be a consumer inkjet printer, a high-volume laserjet printer, or a CMYK printing press.

Simplex

Print only one side on each output sheet.

Duplex

Print both sides on each output sheet and arrange the resulting sheets to be found on the left.

Tumble Duplex

Print both sides on each output sheet and arrange the resulting sheets to be bound on the top.

8.5.2 Finishing Options

Finishing Options are embedded parameters and/or commands in the AFP docs (document, page segment, overlay, or medium overlay) to indicate the type of task to do at the end of printing on a document level. For instance, if Punch is selected, and all the pages in a document are punched.

Punch

The following types of Punch operations are supported by AFP Printer,
The following types of Staple operations are supported by AFP Printer,

- None
- Staple Top Left
- Staple Bottom Left
- Staple Top Right
- Staple Bottom Right
- Edge Stitch Left
- Edge Stitch Top
- Edge Stitch Right
- Edge Stitch Bottom
- Saddle Stitch In

### 8.5.3 Destination Bin Options

Destination Bin Options are embedded parameters and/or commands in the AFP docs (document, page segment, overlay, or medium overlay) to indicate which output bin should be used by the target printer.

Zero stands for the default bin, and one stands for Bin 1, and two stands for Bin 2 etc.
8.5.4 Medium Overlay Options

Medium Overlay Options are embedded parameters and/or commands in the AFP docs (document, page segment, overlay, or medium overlay) to indicate which medium overlay is to be included on every page of your AFP document when the document is printed on the target printer. A valid name of the medium overlay is required.

8.5.5 Form To Tray Assignment Options

Form To Tray Assignment Options are embedded parameters and/or commands in the AFP docs (document, page segment, overlay, or medium overlay) to match the correct paper size with each paper source available on the target printer.

Size

A full list of available paper sizes.

Source

A complete list of valid paper sources available on the target printer. If the "Auto Select Bin" option is selected, Paper Type is matched to Size to determine the media object identifier.

Paper Type

White, Color, Transparent are the three available options.
Top Level Intro

This page is printed before a new top-level chapter starts

Part IX
9 Viewing AFP

AFP document, page segment, medium overlay, and overlay can all be viewed by IBM AFP Workbench Viewer, a free program that helps you view and print AFP docs.

There exist many 3rd-party AFP viewers, but some of them can not interpret or present AFP data stream correctly.

9.1 IBM AFP Workbench Viewer

**AFP Printer** allows you to convert other file types to AFP, and it does not help you open or view an AFP file. Therefore, you would need AFP viewer software to open and read AFP file.

IBM AFP Workbench Viewer Standalone application

IBM AFP Workbench Viewer Plug-in for Microsoft Internet Explorer


- Document: *.afp, *.AFP
- Page Segment: *.psg, *.PSG
- Medium Overlay: *.oly, *.OLY
- Overlay: *.oly, *.OLY

The following type of resources are also supported by the IBM AFP Workbench Viewers,

- Form Definition: *.fde, *.FDE
- GIF: *.DOR, *.gif, *.GIF
- CODEPAGE: *.fnt
CODEDFONT: *.FNT

IBM AFP Workbench Viewers only allow you to view and print AFP
document but does not create AFP document, page segment, medium
overlay, or overlay. To create AFP docs, you are suggested to install the
AFP Printer, which can be obtained from,

http://www.afpdriver.com/AFPPrinter_Setup.exe

If you have any question or need help, contact support@afpdriver.com
Top Level Intro

This page is printed before a new top-level chapter starts
10 Purchase

Why to buy?

The evaluation copy of the AFP Printer software expires after 15 days. You can purchase the full version of the AFP Printer software from our resellers worldwide.

For more information on purchasing,

http://www.afpdriver.com/purchase.html

Billing & Payment

Billing currency: USD, EUR, GBP, AUD, CAD, JPY, CHF.

Payment options: Credit card, Debt card, PayPal, Wire Transfer, Bank Check, Purchase Order etc.

NOTE: The simplest and fastest way to buy our software is to order it Online.

Benefits of Purchase & Registration

After you purchase the full version, you will receive:

- Use of the software beyond the 15-day trial period
- No registration reminders or trial version watermarks on AFP files
- Free updates & upgrades to the latest version & future versions.
- Product support by e-mail totally free.

Delivery Options

You can choose either of the following delivery methods:

1) Download: You will receive a download link to the full version immediately after your order is processed.

2) Download + CD: You will receive a download link to the full version, and the full version software will also be mailed to you on one CD-ROM.
Top Level Intro

This page is printed before a new top-level chapter starts
11 Registration

How to register your copy of AFP Printer?

Before registration you need to obtain a valid license code to turn your evaluation copy into full version copy. If you don't have a license code, you can purchase one from our store, 

http://www.afpdriver.com/purchase.html

To register the AFP Printer software with your license key, you should provide your registration name as well in the Registration Reminder window. Both the license key and the registration name can be found in the order confirmation email sent by our reseller.

If you have trouble in registering AFP Printer, feel free to contact our support team at support@afpdriver.com.
Top Level Intro

This page is printed before a new top-level chapter starts
12 Support

If you have any question, feel free to contact us.

Contact Sales Representative
sales@afpdriver.com

Contact Technical Support Staff
support@afpdriver.com

Contact Reseller in North American
Share-it!, c/o Digital River, Inc.
10380 Bren Road West
Minnetonka, MN 55343
USA

Languages: English

Tel: 1-800-903-4152 or 1-952-646-5747
Fax: 1-952-646-4552

Contact Reseller in European
Share-it! - element 5 AG
Vogelsanger Str. 78
50823 Cologne
Germany

Languages: English, German, French, Italian, Spanish and Portuguese

Tel: +49.221.31088.20
Fax: +49.221.31088.29
Endnotes 2... (after index)